SquidGuard is a URL redirector used to use blacklists with the proxysoftware Squid. There are two big advantages to squidguard: it is fast and it is free.
Building FreeNAS
Adjusted from instructions in the FreeNAS wiki.
Install FreeBSD 7.2
- Boot up the FreeBSD 7.2 installer disc
- Country Selection
- Console keymap
- Installation Mode - Express (Begin a quick installation (for expert)'ts)
- Destination - press "A" to use the entire disk and then "Q" to quit
- Boot Manager - use the FreeBSD boot manager.
- Disk Label creation - press "A" for an auto configuration. and then "Q" to accept and quit
- Package selection - select "Developer". Answer "no" to installing the ports collection.
- Installation media - select the FreeBSD CD/DVD
- General configuration - set a root password, turn on networking and enable SSHD.
- Boot into the new install
Finalize the installation
- Install some necessary tools:
pkg_add -r bash
pkg_add -r cdrtools
pkg_add -r subversion - Install FreeBSD security updates:
freebsd-update fetch install
- Update the port database:
portsnap fetch extract
Replace sh with bash:
cd
cp .profile .bashprofileAdd the following to the end of
.bashprofile
:# set prompt: ``username@hostname:/directory $ ''
PS1="[\u@\h:\w] "
case `id -u` in 0)
PS1="${PS1}# ";; *)
PS1="${PS1}$ ";;
esac - Install PHP:
pkg_add -r php5
Compling FreeNAS
Download the FreeNAS source:
mkdir /usr/local/freenas
cd /usr/local/freenas
svn co https://freenas.svn.sourceforge.net/svnroot/freenas/trunk svn
Compile it:
cd /usr/local/freenas/svn/build
./make.sh
- Log in to post comments